Address verification not working
Incident Report for Nortridge Software
Resolved
This issue has been resolved.
Posted Sep 03, 2019 - 09:23 PDT
Investigating
We are currently investigating this issue.
Posted Sep 03, 2019 - 08:30 PDT
This incident affected: Delivery Point Validation - Address Verification.