DPV issues

Incident Report for Nortridge Software

Resolved

We identified the issue and it has been resolved.
Posted Feb 15, 2019 - 18:18 PST

Update

We got a report from some of our internal pinging systems that address validation may be having some issues. We are investigating.
Posted Feb 15, 2019 - 16:03 PST

Investigating

We got a report from some of our internal pinging systems that address validation may be having some issues.
Posted Feb 15, 2019 - 15:58 PST
This incident affected: Delivery Point Validation - Address Verification.