Address verification (DPV) issues
Incident Report for Nortridge Software
Resolved
This incident has been resolved.
Posted May 10, 2019 - 09:35 PDT
Update
We are continuing to investigate this issue.
Posted May 10, 2019 - 09:30 PDT
Investigating
We are currently investigating this issue.
Posted May 10, 2019 - 09:18 PDT
This incident affected: Delivery Point Validation - Address Verification.