Connection issue
Incident Report for Nortridge Software
Resolved
This incident has been resolved.
Posted May 30, 2019 - 12:30 PDT
Investigating
There have been reports that some users are experiencing connection issues and we are currently investigating this. Will provide an update as soon as it gets resolved.
Posted May 30, 2019 - 12:00 PDT
This incident affected: Switch hosted environment - App stack.