Connection issue
Incident Report for Nortridge Software
Resolved
This incident has been resolved.
Posted Jun 20, 2019 - 09:54 PDT
Investigating
We are currently investigating reports that some hosted users are having issues connecting to Switch.
Posted Jun 20, 2019 - 07:24 PDT
This incident affected: NLS Hosted Servers.